4.8 HEADER MENU

  1. 4.8.1  about sequence headers (general comments)
  2. 4.8.2  sequence header
  3. 4.8.3  multi-database header data
  4. 4.8.4  compose displayed header (virtual blast search)
    1. 4.8.4.1    blast searches
    2. 4.8.4.2    blast and user data
    3. 4.8.4.3    project and imported data
    4. 4.8.4.4    special data
    5. 4.8.4.5    replace database name
    6. 4.8.4.6    search header
    7. 4.8.4.7    create new project
  5. 4.8.5  user comments

4.8.1 about sequence headers

The main Sequence Header form is used to display selected information for each project sequence as selected in the Compose Displayed Header form described in section 4.8.4. In addition the header menu contains options to display the results of a local multi-database search and to add user comments to project sequences.



4.8.2 sequence header

The Header form is intimately linked to the Compose Displayed Header facility to compose the content of the currently displyed header. Individual sequences are often associated with a large amount of information primarily derived from blast searching but also from other analyses carried out with SEQtools functions. It is inconvenient to display all information in the header. A more rationel approach is to select only the information of interest in a certain context.

Navigation, command buttons and icons on the righthand panel are more (or less) selfe xplanatory and will not be described here: Try and learn... The only facility which perhaps should be mentioned is the Copy command button which copies the current sequence to the clipboard (listing the first and last parts of the sequence in the field to the left of the command button.

Below is illustrated and explained one of the features of the header form: For local database searches if is sometimes convenient to be ablt to retrieve the database sequences for a closer inspection. By highlighting a description block in the header (after including the local search in the displayed header) and clicking the fishing rod icon causes SEQtools to retrieve the listed sequences from the database and offer several options for the further action (see the Retrieve menu below).



Retrieving sequences from the local database is not possible unless the database is constructed with the NCBI program FormatDB -o option set to true.



It is also not possible to retrieve database sequences from Genbank with this method. SEQtools does not at the moment include a function to batch retrieve blast matches from Entrez for a single blast description header section. This is, hoewver, a fairly easy routine to add to SEQtools. Should anyone need this facility, send me a word.



4.8.3 multi-database header data

This function was originally designed to compare viral genomes by a French research group. The function is similar to the Local single database search function but accepts multiple databases and has different options for analysing / displaying the result of the search. The function is described in detail on Local single database search under the Search menu.



4.8.4 compose displayed header

This form is the key to controlling display of information stored in sequence headers. Extensively annotated sequences contain a large amount of information in their headers and without a facility to filter this information before displaying it would render the displayed headers rather confusing and difficult to use in a rational way. The Compose Displayed Header form helps you temporily hide irrelevant information. You will see the icon for this form in several places in SEQtools.

The compose form includes three tabs containing checkboxes for all possible header sections, sections without information (for all project sequences) being disabled. To compose the displayed header simply put checkmarks in the sections you wish to include. When done click Build Virtual Search to construct the displayed header consisting of the checked items.

Note that a header section becomes enabled if just a single section in the project contains information in a particular section. Use the Skip Empty Headers to skip sequences lacking information when navigating among headers.


4.8.4.1 Blast searches - Select blast searches to be included in the virtual blast search. Note that the first blastn search is on a local database (PROJECT98). The selection of information from checked blast searches in the list is prioritised: If the first blast search fails to yield a results (i.e., a best match line) the function tries the second selected blast search and so on. The identity of the blast search used for a given sequence is indicated in the project sequence list.

Change the list order by highlighting a line and click Up or Down to shift its position - and thereby its priority.




4.8.4.2 Blast and User Data - Header sections covering Blast resuls and various User comments.




4.8.4.3 Project and Imported data - Various project related sections and sections holding differen types of Imported information.




4.8.4.4 Special data - A collection of difficult-to-classify types of information.




4.8.4.5 Replace database name - List of available local and global blast searches. The File menu includes - in addition to other options - also a delete option. To avoid unintentional removal of header information the following procedure should be followed: (1) Rebuild the list of blast searches, (2) select one blast search (i.e., a single line) and (3) finally put a checkmark in one (and only one) header section. Then click the Delete menu item under the File menu. This implies that you have to delete each section of the header at a time to remove a particular blast search from the header.

Below is described how to alter the name of the databases in the list. This option should also be used with caution to avoid messing up the information stored in headers.

The only situation where this facility is required is really in cases when you import sequences from a different SEQtools project searched with a local database with the same content but a different name. In this situation the two searches on the same database will be listed as two different searches because the database names are different. Changing one of the database names to exactly the same as that of the other search will merge the two blast searches into a single search.



Warning before accepting changes to a database name.




4.8.4.6 Search header - The Search Header function enables you to sear the displayed header for a query text string. Matches are highlighted (in red) when clicking an item in the match list.entire header. If you want to search the complete information stored in sequence headers build a displayed header containing all information stored in the header by clicking the Show Complete Header command button on the Compose Header form.




4.8.4.7 Create new project - A small facility to allow you to collect sequences for a new project while inspecting sequence headers the project. Simply click Add to include the current sequence + header in a new project. When done choo from the File menu of the Compose Project form. Options are: (1) Remove from project, (2) Save multi-sequence file, (3) Open new instanse of SEQtools with the selected sequences and (4) Print list.



4.8.5 user comments

AForm to enter user commets for the current sequence or to the specified range of project sequences. The user information is stored in separate header sections and can be selected individually. See the Project menu for a detailed description of how to use the Edited Genbank description line feature.



   2002-2010S.W. Rasmussen  (revised: )